Radio code? WAIT- how long?

I purchased a 2000 SLK and the battery was replaced. I have the 5 digit code to enter into the radio to reactivate it but the radio just says "wait"
instead of code. The manual says it should stay like that for about 10 minutes after the incorrect code is entered 3 times (which it was;-). I have driven the car for several hours without the "wait" going away on the radio. I have also removed the fuse for the radio for about 1/2 hour,just to see if the "wait" message would go away after all power is removed from it. I have the radio turned on as the manual says that the "10 minutes" is only if the radio is turned on. It is a real bummer to get the car and drive around with the top down without the use of the radio or CD player ;-( Please help Thanks Vince
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Gosh, life's a bitch. You appear to have made incorrect code entries and your radio tries to protect itself and you tell the (newsgroup) world that you're without a radio in a convertible so you can't show off and people are starving and dying...
Sorry.
Maybe somebody else will sympathise.
I hope you appreciate that you can be in a position to voice such a 'terrible' thing...
DAS
--
--
NB: To reply directly replace "nospam" with "schmetterling"
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

the incorrect codes. I was just left with a radio that was in "wait" mode. Much to the disappointment of all of you I have the correct code and "maybe" would have entered it correctly by the third attempt ;-) My frustration comes from the point that the manual states that the "wait" time should be about 10 minutes whereas the dealership is telling me it could take 24 hours of having the key turned on to get the "wait" code to go away and be able to enter the code. Dori- yes the cattle & horses that frequent the back country roads that I go for a leisurely evening drive on here in south central PA will be quite envious of me when I "show off" to them. Thank you all for your "positive" responses. Vince D
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.