Radio Problem in my 300E

I removed my broken becker grand prix some months ago and installed a clarion AM/FM CD player. I went to use turn on the radio and all I get is crackling sound coming outa of the rear speakers.... I have soem type of
sound system with an amp in the car somewhere...
thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Me too - an amp somewhere? I guess it is located under the auto-gear cover. I had my Clarion fixed and no sound when I put it back. Called the kind repair man who said I had probably forgotten to wire the amp with 12v. I fiddle a little and hooked up a loose wire to the 12V and boom boom - it worked. So and amp is somehwhere... I looked in the hood, in the trunck and under the vackseat and front - no - not there. I tried following the wire (hard) and it seems as if they go under the auto-gear cover...
Any ideas?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Make sure that you replace the o.e. speakers when you replace the head unit. The Clarion has four ohm impedance outputs intended to reach like kind coaxial speakers which are also four ohms. The o.e. Becker speakers are junk just like the antique tape/radio which powered them. Make certain that the installation was clean with NEW wires between head unit and speakers. Do not use the wires coming off the o.e., mechanical, rotary fader on the console. The Clarion unit has an electronic fader built into it. The o.e. fader is rated at 50 watts and only the E500 had a fader rated at 75 watts. P.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.