S320 Windows problem

Hi. The windows have suddenly stopped working on my S320. first registered on the 03 11 1995. vin no, wdb 1400322a289959 They were all working fine now none of the switches work and no sound can
be heard when they are operated. The fuses in the trunk are ok and I have tested that power is at both sides of the fuses. I was going to remove the centre console to see if there is power to the switches but thought I would ask you guys first. Are there any fuses for the windows under the bonnet (hood) or any relays. I would have thought there would be a relay somewhere to stop the contacts burning out in the swiches. I can't see it being the switches, it is obviously something that is common to all the switches, maybe a junction link somewhere. Please can anybody give me some advice. Kind regards Chu ( UK )
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
If all suddenly stopped working, then it has to be relay. There should be two fuses for the windows... I would pull them out and change them regardless.
You might also want to pull out your battery cable to 'reset' the system.
If fuse and reset doesn't work, then I'd look into the relay... I don't know much about your car W140... but all the relays are in the fuseboxes.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hi Tiger, Many thanks for the reply. I have changed both fuses and checked for voltage both sides of the fuses and they are ok. I have also disconnected and reconnected the battery. I have been told today there is a relay called a Comfort Relay in the fuse box which I shall test tomorrow. Will let you know what I find. Kind regards Chu

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Chugar wrote:

I spilled coffee on my center console, where the shift handle is located. This disabled the wipers, windows and several other functions. Cost about $600.00 US to fix at the dealer.
EJ in NJ
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.