S500 No Start

After rebuilding the transmission the car will not start. It has Fuel pressure but no ignition. A good crank signal. the battery was disconnected. I cannot find any one who can help I hav called a half a dozen dealers and
they all say it should start after disconnecting the battery. I do not have a scan toll for Mercedes so I cannot see if there are any codes. Can anyone help? Thanks Brian
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Let's get to the basic...
Will it turn over the engine?
How do you know your crank sensor is good?
Did you check your overload relay fuse?
What year is your car?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The ignition key may need to be resynchronized if the battery has been disconnected for awhile.
If the security system loses its key identification code, it will turn over but will not start. A security start lockout feature. The key may need to be resychronized with the security system.
For a pre-SmartKey model, try inserting the key into the driver's doorlock, turning to lock position and holding for five seconds. Then unlock the car and try to start it.
There is a similar resynchronization method for the SmartKey, which is usually in the owner's manual (I don't have my CLK manual right here).
That same response happened on both my ML and CLK (bladed and non-bladed keys), and it seems to me it was just a matter of putting the key in, clicking over and off a couple of times, removing the key and reinserting it to start the engine.
You might try 1-800-FOR-MERCEDES (1-800-367-6372) and tell them you need to resynchronize the key to your S500 after the battery being disconnected for a length of time. It's available to anyone, whether the car's registered with them or not.

disconnected.
have
anyone
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Neutral safety switch?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.