slk 230 engine missfiring

just purchased an slk 230 1998,car is missfiring when cold,coughs and splutters when cold,and also when triing to give full throttle,i cleaned airflow meter this helped when engine is heated up,there was a
fair amount of wet oil in airflow meter,still missfires when cold,also doesn,t seem to pick-up speed very fast,it revs fine but doesnt shift gear seems to hang onto revs,anybody had similar problems thanks giz. :?
--
Posted at author's request, using http://www.AutoBoardz.com interface
Articles individually verified to usenet standards. Visit URL to contact
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I am not sure if you have individual coil for each plugs... if so, probably oil in the hole where spark plugs are.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
mine had an oil leak on the camshaft actuator that caused oil in the airflow meter. oil entered the wiring loom and spread throughout the loom till it came out of the ecu and oxygen sensor, causing oxygen sensor fault codes and rough running. needed parts a1110510177 magnet a2711502733 starter line (modified wiring loom to prevent future reoccurance) wiring loom required flushing out all done by mercedes, cost 560 then required oxygen sensor due to oil contamination 18
"giz" wrote
> just purchased an slk 230 1998,car is missfiring when > cold,coughs and splutters when cold,and also when triing to > give full throttle,i cleaned airflow meter this helped when > engine is heated up,there was a fair amount of wet oil in > airflow meter,still missfires when cold,also doesn,t seem to > pick-up speed very fast,it revs fine but doesnt shift gear > seems to hang onto revs,anybody had similar problems thanks > giz. :?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Hi, My 2001 230SLK -65k miles just had a report from Mercedes Pentagon Southamptom England following service why engine warning light is on and fault is same as Sherlock with oil contamination of Lambda sensor causes by oil through loom from actuator.
Similar cost quoted to rectify incl new engine loom but not had the work done as investigating further Car runs OK still with warning light on but do not know the longer term effect - it did pass emission just Anyone else had the same problem and got anywhere with a concession.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.