Starting probs - 1988 260E

I have a 1988 260E and a few weeks ago, it developed some starting problems. What's happening is that rather than the smooth one-key-turn start I'm used
to, it's taking 2, 3 sometimes four long cranks.
I thought this was all part of an overdue major service ad tune. I sent the car in, and the service was down, but the problem is still there.
I've told the mechanic that I expected the particular problem to be sorted out as part of the major service but he's still unable to pinpoint the problem.
Any ideas on what I might be dealing with (and yes, I'm looking for a new place to have the car serviced!)
Peter
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
When does the delayed start occur? Cold engine? Hot engine? All the time? How many miles / kms on this engine? Anything recently happen?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

thanks this seems to happen when it's both a cold start and hot start - it seems to be all the time, though between breaks it occasionally starts on first turn the engine has 250 kilometres on it and has been regularly serviced nothing major has happened recently
peter
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The fuel pressure ought to be the initial line of inquiry. There's a fuel pressure regulator that, as its name implies, regulates the fuel system pressure to a specification. Then there's the fuel accumulator and two electric fuel pumps, all back at the fuel tank.
Fuel system pressure and volume can be tested so there's no reason to speculatively replace these expensive parts only to find no improvement after your $$ have been liberated from your pocket. Suggest you have the fuel pump pressure checked in line with the starting problem.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
many thanks that's good advice - i'll let you know how i go rgds peter

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Peter,
When the car finally starts, do you see black smoke buff? If so, it could be your injectors or cold start injector leaking. Also check the air flow sensor plate rest position
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Please tell me know how do we look or check the air flow sensor plate? If we nerver adjust it, does the position changed by itself ? Thanks! Quang
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Have the fuel pump or fuel pump relay been ever changed ? Quang
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hi Peter , I have the same problem, After changing the fuel pressure regulator, fuel pump relay, high Vottage protection, problem still there. Finally, bring to good mechanic, he find down the cold start valve is leaking! And the fuel accumilator is bad! He also suggest to changed the 4 fuel injectors (150km). And now my car is good to start now! Good luck to you! Quang
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.