STRANGE 190e problem (clunketa)

Some time ago my 190e made a clunking sound in rythum with the wheel turning underneath and on the left rear side when I turned left to hard or hit a
major dip. It only does this upon acceleration, not coasting or deceleration to the left. If I let it set a while it would not do this until it went a few miles. then it quit doing it for some time, not a sound. Then after a time it started again. I took all the extra weight out of my trunk and that did it, not a sound for some time. Now it is starting to make the sound again. You turn left on acceleration and there is a metalic clunka clunka some times. I also have a lot of drive shaft slap with shifting down as I approach a stop. But it has been like that for 50 thousand miles. It almost sounds like its in the wheel or something in the left rear. Anyone have an idea what to look for before I jack it up and look??
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I would suspect your sway bar links broken... check them and replace them.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I'll guess it's part of the ebrake...
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.