TEMPERATURE QUESTION

I Have a 1989 560 SEL. My temperature gauge always (when engine is up to operating temp.) reads above 80 C. I wonder if this is normal. I had the radiator flushed in Jan. of this year. Along with the thermostat. Am I at
the right operating temperature?
TIA,
Bill
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
My 2001 E430 always reads above 80.......usually 85-90. Every loaner car I have ever driven (usually E320's) has run in the same range (85-90).....so readings above 80 are normal.
BG wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
What does BG want? Temp of ice?
;-) DAS
--
For direct contact replace nospam with schmetterling
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I think he is concerned because the needle runs above the middle of the temp guage. I was too, until the dealer assured me that that was very normal and I proved it to myself by driving several other models and they all ran above the middle of the temp guage. The new models don't even have a temp guage....they replaced it with an analog clock.......a step DOWN, in my opinion.
Dori A Schmetterling wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Yep... normal.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.