Transmission Problem on W202

HI There,
I got a problem when shifting the lever from Neutral to Drive position. Whenever I shift from N to D, the car jerks and shift into the drive
harshly. However, If I shift from neutral to reverse, it shifts very smoothly.
Can anyone advise where the problem is? I have checked the drive shaft and the rubber coupling, and there was nothing wrong or lose.
Any suggestions will be deeply appreciated!
Many Thanks, Joe.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Is the motor cold when you shift into drive?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The shift jerks when the engine is warm as well.
Please help.
Many Thanks, Joe.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Does it do it consistently? My 91 300CE does the same thing most of the time, but sometimes it shifts smoothly. Very weird.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Yes, it does it all the time. The car jerks only slightly, if shifting 'very slowly' from neutral to drive. to let the oil pressure stabilise a bit before shifting to the drive gear fron neutral, and let the clutch to engage slowly.
Any inputs will be welcomed!
Many Thanks, Joe.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Having the trans fluid flushed and replaced and replacing the pan gasket helped the problem tremendously. Now it only does it sometimes.. there is still a small leak in there somewhere. Is there any leakage coming from your tranny?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Yes, it does it all the time. The car jerks only slightly, if shifting 'very slowly' from neutral to drive. to let the oil pressure stabilise a bit before shifting to the drive gear fron neutral, and let the clutch to engage slowly.
Any inputs will be welcomed!
Many Thanks, Joe.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.