Transmission Trouble E320 Wagon

I want to post a primer for the groups review. Here are the Cliff Notes:
1. Bought a 95 E320 wagon for the wife in November. 2. Tranny went south about 6 weeks after purchase. No reverse means B3
pack is shot. Car had 150k, so the trans did it's job (even though the one in my car went 300k). 3. Ordered replacement from a shop (remaining nameless for now) that I've done business with before. I used them to supply a transmission for my car about 16 months ago. On my car, ordered the transmission, worked with them on the install (did it in my driveway) and had no issues. Car is still shifting fine. 4. On the wife's car: I followed the flush instructions as well as all other info provided by the shop and the install went fine and car shifted great until last week (roughly 2 weeks after the install). It stopped shifting above 2nd gear. Diagnosis is bad or clogged valve body.
The issue now is that the shop will charge me for a new valve body if there is contamination in the old one (despite following their directions).
I think they should replace it under warranty and extend the warranty beyond the 12 months (they offer a longer warranty for an additional charge).
I'm open to everyone's thoughts at this point. If they take care of the issue, I won't post the shop's name. If they don't, I think you guys should know where not to buy your next transmission (God bless you if you have to buy one at all).
Please post follow-up with your thoughts.
Thanks, Todd

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
Add image file
Upload is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.