Use of 140 weight gear lube in rear end-1998 C230 MB ?

I suspect I have a worn pinion gear (scuffed?)which is a bit noisy. I was thinking maybe a heavier weight 80-140 weight lube might quiet it down abit for the time being. I am not in a big hurry to replace it at
this time. Is this a bad idea.? Before we bought the car it appears that the rear end seal had been leaking and might be the reason the pinion is acting up now. Not a big problem just a noise nuisance. Thanks.
larry
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Just replace the seal and put back specified gear lube. We once had a 190E with same problem and was driven a long time with very low lube... replaced and refilled and the problem is gone.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Tiger wrote:

We already replaced the lub.. seal was fixed.. but noise got a little worse after recently replaced the lub. He put in 80 weight...maybe previous to that it was 90 weight ?? ... Now I'm thinking 140 weight..Will 140 weight damage the rear end drive if it is too heavy for the MB application?? Thanks
Larry
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Mmm... maybe he put in the wrong grade... call up LubroMoly or Mobil and ask for their recommendation.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.