vacuum pump for '95 s420

i have a '95 S420 with a broken vacuum pump. the replacement is about $800, but i can get one from a late model for $250. i understand that there is
some kind of adapter you can use to make a later model pump work on older ones. anyone know anything about this? thanks.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
i have a '95 S420 with a broken vacuum pump. the replacement is about $800, but i can get one from a late model for $250. i understand that there is some kind of adapter you can use to make a later model pump work on older ones. anyone know anything about this? thanks.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Which vacuum pump? The one in the trunk, left side, for closing assist? Or the one under the rear seat, right side, for central locking?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
thanks for the reply.
under the seat - central locking.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
thanks for the reply.
under the seat - central locking.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Yes, you need to buy a few more parts. I can get a list of them tomorrow. Do you have OSB [othropedic seat backs]?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
not that i know of! btw- that does the heat dampers as well, correct? (no heat to the floor now)

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sort of. The pump supplies additional vacuum to Y11 when the engine vacuum supply drops, i.e. when you are pulling a long hill. Y11 is the vacuum gang block under the pass floor panel.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
actually, you know i guess i do have the ortho seat backs. i wasn't connecting with what you were asking, but there is a thumbwheel on the outboard sides of the front seats to adjust the lumbar support. i guess that's what you're talking about. the thing about the floor heat is that it's not there right now, but i'm pretty sure that it's because when i took the pump out to examine it, i pulled all the vacuum lines off to get it out of the car. when it was obvious that the motor was fried, i just left it out of the car. but i discovered the hard way that you can't start the car with it disconnected. so i put it back in with the electrical harness attached, but the vacuum lines off since it's a bit of a pain to reconnect them. now i have no floor heat, but i don't feel like pulling the back seat out again until i have the new pump.
thanks again for your help. looking forward to seeing the parts list.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.