Washer motor failing? W123

The rear washer won't spray in my '79 300TD. According to that Russian site that is often cited here, the motor is the same one that's in the front of the car.
When I hit the button on the dash, I hear the motor spin, but again, nothing comes out of the nozzle.
Up front, I had to swap out the check valve which had frozen, and it appears to be the same part in back but I haven't yet located it. However, I'm wondering, now that it's all back put together and I'm cleaned up and about to order parts, what's the likelihood that the motor itself could be failing? The check valve is like $3 so I might as well get it. The motor is $12, which is enough that it's not a big deal to just get it and be done with it, but is money that I could also spend on a burger and fries when the job is done.
Any thoughts?
I discovered today that the reason why the rear window wiper didn't work is because it was disconnected from electricity. Not sure yet why it was disconnected, but the arm was also barely attached so I tightened that up and everything seems to work a treat. The joys of buying a 28 year old car. ;)
-tom!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Just change it like you said. You got nothing to lose.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.