Weird car

I just had my 91 300CE serviced and had the ignition control unit and rotor button replaced. The mechanic who checked it out said everything appeared
to be fine, and the car has been driving great since. But tonight I took it out in 32 degree (F) weather, drove for about 10 minutes, parked it momentarily, and then drove it again. After about 10 minutes, while sitting at a light, the car mysteriously stalled. I cut off the ignition, turned it back on, and everything was fine. My obvious question now is: why did it do this?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
If it reoccurs - intermittently or more regularly - have the fuel pump relay checked.
It's the fuel pump's ON / OFF switch.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The car did it again today, but I noticed something I failed to mention in my original post. The car was "low" on gas. When I say "low" I mean the gauge was reading (what I thought to be) about one-quarter of a tank, maybe a bit less. I've never run it that low before so could this perhaps be the problem? I filled it up immediately after it cut off again today, and it's been fine since. Might I still have a fuel pump relay problem?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
If it just stopped, I'd check the fuel pump relay. Normally a fuel related problem wil cause the engine to stumble a bit before quitting.
Dick
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.