Window defroster

Hi everyone,
I used my front window defroster today and I had warm to hot air hitting the windshield then me. I have an 1989 560SEL. I can't figure out why this is
happening. I rolled the auto climate control to it's lowest setting, and still nothing, I still got hot air out of it.. The auto climate control "knob" works for the cars normal hot and cooling temp mode. I'm puzzled. Any ideas?
Bill
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I don't know how the system works on an 89, but on my 80 300SD, selecting defrost calls for max heat and there is no choice, regardless of where the temp select is set.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Same with my 1986 190E 2.3-16. There is a defog setting which aims the air at the windshield but lets you manually select the fan speed and temp. Then there is a defrost setting which aims the air at the windshield but also selects high fan speed and max. heat. You could achieve the same thing in defog mode by manually making those selections, but defrost mode is a convenience feature.
Bill Balmer 1986 190E 2.3-16 first 16V in the US featured in Car & Driver - March, 1986
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.