wiring harness R&R for '96 E300D

I have been told by a mercedes mechanic that I need to replace my engine wiring harness. Does anyone know how much labor is involved with such an operation ? I have acquired the part & am considering doing the job
myself.
Thanks in advance !
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It takes a while to do but I do not recall this year having engine harness problem... this problem was typical of earlier models... but not yours.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Tiger wrote:

http://www.mercedesshop.com/Wikka/M104WireHarness
This is for the M104, but the method should be similar.
Regards, ws
--
a = leews b = pacific.net c = sg

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hi,
Thanks very much for the link ! I noticed it said in the link that the cruise was not working.....I have had similar problems including intermittent speedo function. Is this your link ? If so, did you have similar problems ? If not, do you know how I can contact the originator of the link ?
Thanks in advance,
Brian
ws wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.