1990 Toyota Camry, check-engine light comes on, car doesn't accellerate, stalls

My car runs, but sometimes, not every time I drive it, the check engine light comes on, and the car won't accelerate when I step on the gas, and sometimes it dies, and won't start again right away. I have to just sit and wait. Then, all of a sudden, it starts just fine, light goes out , and it runs fine for a while. It happens infrequently. It wouldn't do it when I had it at a shop recently to have the starter replaced. When I drove off, the light came on, but car did not die then. 15 minutes later light came on, car stopped accellerating (on a busy highway!)for a few sec's, then light went off, and it would run normal. Could it be the ignitor? Some loose connection? I really can't afford to put it in the shop on a diagnostic machine, Can anyone help me out?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Need to have the codes read, then we will talk

--
Stephen W. Hansen
ASE Certified Master Automobile Technician
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

How do I have the codes read? thanks

--
Message posted via http://www.carkb.com

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Jumped the circuts in the little grey diagnostic box under the hood, The check engine light falshed twice, then flashed twicw again, like . . . . "flash flash (break) flash flash", and would repeat this sequence. The temp. gauge on the panel is not working, but that is not causing the car to do what it is doing. I am going to disconnect the battery cables, and read the codes again. still need help finding what's wrong with the car. thanks

--
Message posted via http://www.carkb.com

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

code 22, "flash-flash . .flash-flash", etc., etc.,?????

--
Message posted via CarKB.com
http://www.carkb.com/Uwe/Forums.aspx/toyota/200505/1
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Joan McCrackin via CarKB.com wrote:

Um - it could unfornutately be almost anything, but the MAF is the first thing I'd look at, along with a dead 02 sensor.

I noticed a thread there about some guy complaining that because a Crown Vic going 20mph hit his son's car and totalled it, he'd not going to buy another Toyota.

Just figuring out the impact forces 5-10mph, 20mph for the two cars, and the weight difference, it's like smacking head-on into a wall with that Matrix at 40mph or so.

Heh. I'd carry full coverage and count myself as very lucky.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

"Joan McCrackin via CarKB." wrote: > My car runs, but sometimes, not every time I drive it, the > check engine > light comes on, and the car won't accelerate when I step on > the gas, and > sometimes it dies, and won't start again right away. I have to > just sit and > wait. Then, all of a sudden, it starts just fine, light goes > out , and it > runs fine for a while. It happens infrequently. It wouldn't do > it when I > had it at a shop recently to have the starter replaced. When I > drove off, > the light came on, but car did not die then. 15 minutes later > light came > on, car stopped accellerating (on a busy highway!)for a few > sec's, then > light went off, and it would run normal. Could it be the > ignitor? Some > loose connection? I really can't afford to put it in the shop > on a > diagnostic machine, Can anyone help me out?

Same problem here.. My 1989 Toyota Camry LE w/just a 100,000 miles on it Will not accelerate, starts up just fine, then I tried to move in 1 and 2nd, gear still wont go, then 10 minutes later it goes. Plus I have to go down now and see where it is leaking from... First time Ive had a leak.

Let me know if you found out how to fix the acceleration problem, very scary if it stops going when youre making a left onto a busy street!

Thanks (Im new, my first post)

--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I just had a new tranny put in last fall, started out doing what yours is doing.

--
Message posted via CarKB.com
http://www.carkb.com/Uwe/Forums.aspx/toyota/200505/1
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Related Threads

Nothing found yet

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.