Mercedes Autos and SUVs - Main Page

Mercedes Autos and SUVs -Mercedes Luxury Autos and SUVs discussed here. This forums is a Web, Mobile and Social Media interface to alt.auto.mercedes.
There are 55333 articles in 12095 discussions. See the most recent and the best rated articles in Mercedes Autos and SUVs

The most recent discussions

Radio dont work


January 15, 2017, 2:14 am

Went to replace the antenna complete and the pig tail came apart and the wires touched and the fuse blow for the radio replace the fuses for the radio and still dont work will work if i jump the blue... Read more »

Mercedes rolls out Sport Package Plus for CLA250


March 8, 2016, 1:19 am

If you dig the style of the Mercedes-Benz CLA-Class but can't quite stretch from the $29,900 MSRP of the CLA250 to the $47,450 CLA45 AMG, we've got a bit of good news for you: Mercedes is offering a ... Read more »

Mercedes rolls out Sport Package Plus for CLA250


February 5, 2016, 8:36 am

If you dig the style of the Mercedes-Benz CLA-Class but can't quite stretch from the $29,900 MSRP of the CLA250 to the $47,450 CLA45 AMG, we've got a bit of good news for you: Mercedes is offering a ... Read more »

New batery for Mercedes 500SL


September 30, 2015, 3:35 pm

MB 2005 500SL uses 2 batteries . One on the engine compartment and another on the rear trunk. I have replaced the one on the back but now the one in the engine compartment is finished. Dealer wan... Read more »

09' E350 4Matic Transmission going into "safe Mode"


September 28, 2015, 7:43 pm

My 09 MB 350 recently has started going into safe mode occassionally (i.e. going into 2nd gear and reverse only top spewed 30mph) it clears after a while and immediatrely if I pull over and stop an... Read more »

Navigation System Not workingplease


May 16, 2015, 7:39 pm

Navigation System not working on 2005 500SL Some people belives the problem is a defective cable from the Nav.System probably the one that uses fiber optics. The dealer tested everything and belie... Read more »

1995 W202 C280 AMG transmission problem


May 13, 2015, 2:06 pm

hello good people can you please help me.I have a transmission problem on m y C280,it has a 722424 gearbox.the car started jerking on takeoff and when driving felt like it was slipping on gears.a... Read more »

Coolant temperature display & intermittent engine chugging


April 10, 2015, 6:47 pm

Hello. I have a Mercedes E350. A week or so ago I started to get coolant temperature warning lights (frequently but not continuously). I topped up the radiator with a glass of water but the warni... Read more »

car seems to b flooding wont go over 40 190e 1987


February 23, 2015, 3:06 pm

ran just fine! had sat for awhile it started dieng out at about half tank. figured trash in gas ao changed fuel filter! ran good bout a day. now idles funny wont acelerate ! if u turn off then on w... Read more »

C250 hop up need power


October 18, 2014, 11:44 am

I need jb tune for c250, downpipes hop up parts Faster to reach me 3059729896 text Read more »

Click here for other recent discussions »

The best rated discussions

E500 135mph limiter..how to remove? rating: 5

  [ 2 ]

2003 E500 has speed limiter set at 135mph, can this be removed or deactivated? Thanks, Grant Read more »

W220 S CLASS poor throttle respond rating: 5

Hi all, Yesterday an S320 came and complains about poor throttle respond, i drove the car and found that the car's mileage is only 10000 km and needs some minor service.... after some servicing... Read more »

CLK 200 Open Circuit P0130 Oxygen Sensor Upstream rating: 5

Hi friends, I wonder if anyone can help me. I have a CLK 200 and keep getting the engine management light on with the computer reading Open Circuit P0130 Oxygen Sensor Upstream I have changed the Oxy... Read more »

ML320 Won't Start Reliably rating: 5

While travelling to vacation, we stopped for gas and my '99 ML320 would not restart. It turned over fine but would not run. The fuel pump was replaced @ about 40,000 miles and it now has 98,000 mil... Read more »

2003 C200 Kompressor - Squeaky Suspension?! rating: 5

Hi everyone! I have a 2002 C200K and the there seems to be a squeaking/creaking noise coming from the front suspension. I will be taking it back to the dealer on Monday but just wondered if anyone h... Read more »

1984 W123 230CE (or 230E I guess) Cold idle speed question rating: 5

Not sure I have a problem, but when the car is cold (1st start in the AM), it idles too slowly and is very 'juddery'. Putting it in D helps a little (as the vacuum controlled ignition retard function... Read more »

ABS light on and high edle 560sl help rating: 5

Group, My ABS light came on as I was driving my 1986 560sl and two blocks later when I went to stop I found that my engine will not idle below 1500 RPM.. I feel that these two things are connected a... Read more »

89 560 sel emissions failed ! rating: 5

Thanks for taking the time to read this. I have a 89 560SEL that has failed the my air emissions. Before i pay for a new catalytic converter (What a SHOCK on the COST of a NEW CAT) is there anything ... Read more »

W123 R134 Conversion rating: 5

On the system there is a pressure sensor and a temperature sensor. I am assuming that the pressure sensor is to prevent the compressor from running if the refrigerant level gets too low. The temperat... Read more »

1995 W202 C280 AMG transmission problem rating: 5

hello good people can you please help me.I have a transmission problem on m y C280,it has a 722424 gearbox.the car started jerking on takeoff and when driving felt like it was slipping on gears.a... Read more »

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.