Need advice please on fuel injectors. '96 Blazer

1996 Blazer with 102K mi, replaced dead fuel pump 3 weeks ago and running fine until two days ago.
Now its main symptoms are hard starting (like flooded) after sitting
overnight or for several hours. After it finally sputters to life it runs fine and will restart without problems. Restarts just fine while hot.
I've done a lot of looking on the web and now suspect the fuel injectors. Are they leaking and causing the flooding? Or could it be something related to the new fuel pump? (I hope not). If needed I will end up buying a fuel pressure guage.
If I was able to change the fuel pump which was a PIA, how much trouble will the injectors be?
Many TIA
Steve
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Tue, 29 Aug 2006 17:51:49 -0500, "Mr. Transistor"

I think I would do a fuel pressure check before I went any further. It should be 60 to 65 PSI on a Vortec motor. ----------------- TheSnoMan.com
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
trust SnoMan he was exact on helping me on my 96 blazer. pressure test did it.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.