1996 Ford Crown Victoria

My car has problems going when its warmed up it starts jerking and not getting any power and my overdrive light blinks off and on it doesnt go much faster than 45 miles an hour and it takes a long time to get to that
speed. Please help me figure out what the problem is i dont have much money to get it looked at! Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The only thing that the original posting 'sounds like' is that there is something wrong with the transmission. That's what the blinking O/D light means. The rest is speculation - and I don't know based on what. By the way, I don't know what 'repacing' of a catalytic converter means, but a Crown Vic of that vintage has four oxygen sensors, not one.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Try replacing the gas line filter under the car.
_______________________________________________________________________________ Posted Via Uncensored-News.Com - Accounts Starting At $6.95 - http://www.uncensored-news.com <><><><><><><> The Worlds Uncensored News Source <><><><><><><><>
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The coils on the spark plugs (whatever the hell they call them) could be a problem. My brother has a CV and was getting surging and bucking because some of the coils were bad.
On 16 Jul 2005 15:12:28 GMT, snipped-for-privacy@comcast.net wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.