3.1 miss

Hi I looking for a little help with my 1990 3.1 chevy cavalier. It idles ok with a slight miss but lately the power has gone away. It feels like it's running on 5 cylinders but sometimes it will
clear up and run fine for a week or so. I have replaced the plugs,wires, coil pack, gas filter, air filter and cleaned the throttle body. Also about a year ago I replaced the crank sensor for a no start problem, and the map sensor. It has 195000 miles on it and i would like to get a few more. Thanks for any help.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Do you think the problem is always on the same cylinder? Can you do some further checking to find out?
Is your fuel pressure satisfactory?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I couldn't tell which cylinder wasn't firing so I started pulling plug wires. I found out there is no spark to #4 from the coil pack. I tried another spark plug wire and still no spark so I guess I got a bad coil. I will swap it with one of my old ones to see if I get spark. It's a shame they put the coil pack on the bottom of the motor. They are a pain in the butt to change.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.