03 tiburon MPR read out won't work.

I just got back my 03 Tiburon from getting the clutch changed. I need to take it back because the MPR won't work. I check the connection,and it is ok. Anyone know what could be wrong?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Just check the other chat rooms on this problem. It could be the Speedo Sensor. Just changed it NO GOOD! Still no Speedometer!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

Just check the other chat rooms on this problem. It could be the Speedo Sensor. Just changed it NO GOOD! Still no Speedometer!
What is this "MPR" thing you're trying to get working? Why are you changing parts out before you take it back to the shop that did the work? What do you mean by saying you checked the connection and it is ok?
--

-Mike-
snipped-for-privacy@alltel.net
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
More commonly, the issue is wear on the plastic gear attached to the speedometer sensor. Pull the sensor back out and check to see if the gear is worn to have a concave contact are. If so, replace the gear. While you're there, check the wiring to the connector and make sure it isn't broken.
-- Message posted using http://www.talkaboutautos.com/group/alt.autos.hyundai / More information at http://www.talkaboutautos.com/faq.html
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Ok here we go. The reason I started changing parts was. The shop that did the work was a buddy of mine. He just finished it before going on vacation. I couldn't wait a week. Auto Store told me I could bring the sensor back if it didn't help. I usually do all my own work. I just never changed a clutch on a front wheel drive car. I solved the problem! While I was checking the other chat rooms I found some one in the past that had the same problem. What happen is Hynudia has some of the sensors with the same plugs! The MAF(Mass Air Flow) sensor and Speedo sensor was switch. switched connections and runs like a champ. O by the way I ment MPH . Just some info- If you ever need to change the Speedo Sensor. It's a piece of cake. took me 5 minutes. I can't believe a Dealer charged someone 800 dollars to change one. The part cost 70 dollars at Auto store.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.