HUGE PROBLEM with 99 Rodeo 2WD 3.2L

To make a long story short I got stuck today while mudding with my friend, was wedged in a decline in between a stump and couldnít back up; left rear tire was half-way up in dirt. We finally got someone to
pull us out, and on the way down we heard a big scrape, what sounded like a rock against the exhaust or something of that nature... While driving the 5 minutes home as soon as we pulled in I heard a LOUD scraping noise, what sounded like the exhaust system dragging against the concrete; So I got out and checked it, everything appeared to be fine; We pulled over a little ways down and found out that oil (or what I think was oil) was leaking at a pretty fast pace, in drips. I canít figure out if what I scraped was the oil pan, but that wouldnt explain the loud grinding noise + vibration I hear/ feel; It only does it when I go forward, as the ass end points towards the ground, but in reverse, you can hear almost nothing. Any ideas to what it may be, or how much it would cost to fix it? Any help would be appreciated!
Posted using the interface, at author's request
Articles individually checked for conformance to usenet standards
  Click to see the full signature.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
Add image file
Upload is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.