Need help or advice on 91 Trooper that won't shift into second

Fellow Isuzu Enthusiasts, Does anyone out there have any idea why a 91 Trooper w/ the V6 and auto trans won't make the shift from 1st to 2nd gear? Auto trans is full of
fluid, fluid looks good, and first and reverse work fine. The owner has ensured the "winter" and "power" switches don't do anything to change this, either. I don't know who made this tranny for Isuzu - but my guess is that the 2nd/3rd clutch or planetary gearset is not being operated (perhaps by a defective servo) or a bad band?
I'm not an auto transmission guy, but I do know a little of what they are supposed to do. This one reminds me of the old GM turbo 350's that had a vacuum modulator that was defective, but even those shifted at high rpm (with a bang!) due to the something inside reaching a setpoint despite the vacuum modulator not working. I don't know if this Isuzu transmission even has a modulator, and with the "winter" and "power" switches, it must have some electronics inside.
Does anyone have any ideas on this? thanks in advance, Steve
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
GreenGas wrote:

it's likely the GM tranny but even if not, have you disconnected all harnesses, cleaned them and reconnected? has the fluid filter been changed? if not, drop the pan, remove old filter and replace new (Napa parts kit cost under $35) all fuses been checked? no other electronic&electrical issues with the car?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.