1987 300SDL - Rings

My 1987 300SDL has developed an oil ring related problem, according to my mechanic. The oil ring in one cyclinder is not functioning propoerly, which
allows oil into the cyclinder. On cold start, the accumulated oil is causing a very rough idle. Is there anything I can do about this.
Paul Barbeau 1987 300SDL 133,000 miles
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Oil doesn't flow upwards, what oil can accumulate in a cylinder from a bad piston ring?
If any lube oil is accumulating, which is doubtful, it's seeping down a valve stem because the plastic valve guide seal is worn. But doubtful.
Suggest you add some Techron or similar injector cleaner to the fuel and check that all the glow plugs are working.
Cold starts are the true test of the injectors, any minute bit of carbon or dirt will cause knocking and roughness. Don't get talked into some unnecessary work.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
ummm... There is a shitload of oil splashing about in an engine while its running. the job of the oil rings is to scrape most of it off, so it does not get into the combustion chamber. Some oil is needed to keep everything lubricated.
This may or may not be so much of a problem with diesels, its not good for petrol engines though.
T.G. Lambach wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.