loss of power........explained

So, I'm driving down the highway and I engage the cruise control on my 84 300SD when suddenly I have a loss of power--nothing. I get down to about 10mph and I can go again--get up to 15 or so and
then no power.
I pull off to the center lane off the highway and consider limping home, but there's no way to get back on at 10mph.
I pop the hood, look around and notice the throttle linkage looks funny.
Bottom line--the little circlip or eclip had come off the front of the linkage that the cruise control pulls on and that rod had pulled out of the little arm it goes into.
Shoved it back in, got home fine--not using the cruise control and fixed it with a little eclip from Home Depot.
Just a tale to tell in case you experience a loss of power some day while using the cruise control.
Jeff
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
This shows good design...a part falls off and the engine slows or stops.
I had a SAAB where the throttle linkage fell off and the engine went to full speed. Rather scary!!
EJ in NJ
Rooster wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I think it depends on the part. I've got a hunch that if the return spring were to fall off, the MB could stick at WOT.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.