speedometer not working 1984 300sd

The speedometer and odometer on my 1984 300sd stopped working. The other instruments are working fine.
There is not a speedo connected to the back of the
cluster on this model. Is there anything I can do or check on my own or is it off the shop?
Thanks, Jeff
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Replace the fuse for the speedometer in your fusebox... take it out and replace it with a new one.
The odometer is a different case, it needs to have the gear replaced... if you are handy with tools, you can replace it yourself.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
http://www.odometergears.com /
Buy complete set of three gears... do not just replace one.
Otherwise, send the cluster out for repair.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I pulled the cluster and all the gears for the speedometer/ odometer weren't slipping and seemed fine.
I then got under the car and poked around the transmission area. I found the small metal (magnetic?) cylinder that goes into the transmission had come out and was hanging by it's wires. the screw that attaches this to the transmission was missing. A truly easy fix!
Speedometer works fine now and I painted the instrument needles while the cluster was out.
I am now a happy Mercedes camper.
Jeff
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.