finally totally fixed :)

i have that '88 new yorker turbo that some people have flamed at me for posting about. just thought i'd share what happened.
thing would start, run, stall, start, run, stall, start, drive, stall..
over and over...
so i started with the fuel pump. replaced.
replaced the O2 sensor, the MAP sensor and lil barometer thing that goes with it.
replaced the TPS.
replaced the coil, plugs, wires, stater sensor and battery.
replaced the relays, all of them, one by one. checked fuseable links, went over wiring, unclipping and reclipping a lot of things.
changed the oil. checked for a plastic bag in the fuel tank, maybe i had left one in there when i changed the pump, who knows? =S
swapped out the SMEC.
re-tubed the EGR system...
now it runs AWESOME.. but still stalled. and it would be hard starting. turns out i had two problems.
1) ASD relay was still bad. guess i bought a pooched one at the parts yard. no now it starts up all the time no problem. but more importantly, i fixed my stalling problem.
2) the distance/speed sensor. after some reading, this was apparently the problem the whole time. $5.33 for a couple used ones, and this car has become near-flawless.
next up is to fix my coolant leak cause i forgot to buy some sealant when i picked up a thermostat and a gasket. then i'll be fixing the neutral safety.. gotta swing across from 'P' to '1st' a couple times to get it to turn over.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
glad its running
my advise is never buy electrical or electronics from salvage. you never know what condition its in.

yard.
fixed
i
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.