1995 Chevy S10 4x4 ZR2

Hi, Iam having a 4 wheel drive problem I have no idea what it could be. When I put the truck in 4low all 4 tires do not spin when I brake torque it only the back do. But when I put it in 4Hi all tires spin
what would cause this problem? Thanks for your help..
Jacob
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hi, Iam having a 4 wheel drive problem with my 1995 chevy S10 4x4 ZR2.
I have no idea what it could be. When I put the truck in 4low all 4 tires do not engage only the back do. But when I put it in 4Hi all tires engage what would cause this problem? Thanks for your help..
Jacob
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@gmail.com wrote:

If in fact, this is the story, the whole story and nothing but...then I'd suspect you have a mechanical problem inside the t/case. If you have the equipment available, jack the vehicle right off the ground and see if your front driveshaft is turning when in 4lo. This will eliminate/confirm where the problem is.
Ian
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Ok, so I was wrong 4wd doesn't work period but the light change over and I can here it transfer underneath and the front shaft spins but not the tires... any Ideas? Sorry for my explaining I'm not an automotive professional as you probably already knew that. :) Thanks for the help!!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.