89 k5 front axle ?

89 k5 silverado blazer 5.7, 700r4, 4 wd, manual lock, solid front axle I have a "ticking" "clicking" sound coming from my front wheel. I presume
it is the bearing. Can the bearing alone be replaced or do I need a hub assembly. Or could this be something in the brake? The center of the wheel gets hot. No rolling resistance or bias pull felt. Any ideas appreciated...
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
With the wheel removed, it sounds like it is coming from the lock for the 4wd... A diagram of the assembly would help. Any links there?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Does it have automatic or mubs hubs?
On Thu, 07 Jun 2007 19:21:36 GMT, "Black Dog"

----------------- TheSnoMan.com
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
...manual hub locks One is broken and making a ratcheting sound when the wheel is turned. Engaging the lock and turning the wheel makes no difference. I'm debating whether to go with warn hub locks or GM oem. Any thoughts ? I rarely use the 4wd, usually just to get unstuck maybe 2 or 3 times a year and no serious offroading. The only difference I can descern is the dial is metal or plastic. The actual engagement part looks the same.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.