92 s-10 blazer 4.3 vortec with NO POWER HELP!!!!

I have a 1992 Chevy S-10 Blazer 4wd auto, with a 4.3l Vortec V6. It has a new fuel pump, filter, spark plugs, plug wires, rotor, cap and computer. It has also had the cat converter cut off. The timing has been checked and
is dead on. The problem is, it has no power at highway speeds. It will roast the tires off sitting still doing a power stall. But going down the highway it will only get up to 65 mph with my foot on the floor and any little hill will make it pull down to 45 - 50 mph. It was hooked up to a computer for diagnosis and it showed nothing wrong.
I am willing to listen to any comments. Please HELP!!! Thanks.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Not saying there is nothing wrong with you blazer, but that is the nature of the vehicle. I've had 2 blazers and top end wise they had no power at all. Does it misfire at all at those speeds, any service engine codes?
http://www.carforums.net/ Auto Forums
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It must have been your gearing.
My 1992 S10 had 300K on it and I pulled a 3200lb camper at 75mpg on the interstate. No problem.
Without towing I can easily pass at 70 or higher. It's 55 to 65 that it is a little doggy.
Lannie

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
LS wrote:

WOW!!! 75 mpg is awesome, you must have been at idle speed...

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
oops!!!!!!!! Ya it gets great mileage. :)
Lannie

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
okiecop wrote:

EGR maybe?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Replace the fuel filter, check for Cat blockage, get a press. gage on the o2 port, see what you have underload.

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.