engine only starts if you give it starting fluid

4.3 1998 chevy motor will not start or attempt to. were sure it has to do with the fuel not getting to the cylinders. when you spay starting fluid in there it starts right up. we replaced the relay for the fuel pump but
that still doesnt work.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
marshman wrote:

Have you replaced filter and checked fuel pressure?
----------------- www.thesnoman.com
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
no do you have any other ideas whhile were at it
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
check the gas tank for gas. old john

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Out of gas, Bad pump, plugged fuel line, bad regulator, bad fuel injector unit.
Pump - open gas cap and listen for the pump while someone turns the key to ON. No noise = bad pump. Noise = pump is turning. Check fuel pressure at port on fuel line under hood. 55-61 psi. OK, Less and you have a problem. Change the filter and test again. Still low = Bad pump or pressure regulator.
-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
don't forget to beat on the bottom of the tank
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Does it keep running, or die?
Al
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
check the fuel pump, you should hear it make noise in the back when you turn the ignition switch on

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
2 problems know to all gm, well basiclly all modern fuel injected vehicles. Ignition module, fuel pump. These are not the only problems but if it wont run start here 1st. You have already ruled out ignition. Does it run on its own after it starts off either? If not locate the schrader valve on fuel rail(looks like tire valve stem) check fuel pressure. No fuel pressure? verify voltage out @ relay. Got voltage there,verify voltage @ fuel tank connector. Got voltage there? if so verify ground if good ground time to drop the tank and spend 80.00 on a fuel pump. Oh yea if it will run after it starts on either check your batter condition. Make sure you are staying above about 9volts while cranking.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
my 93 4.3 did the same about a year ago. turns out the small electrical connector to power the fuel pump(connects the wiring outside the gas tank to the wiring inside the gas tank)went bad.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Related Threads

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.