A4 battery woes

Hi guys,
I have a 97 A4 with 50000 miles on the clock. About 6 months ago I get in it without driving it for a couple of weeks and nothing - I notice
the central locking is sluggish and the volts are very low.
So I get a jump start, get on my way and forget about it. problem never reoccurs until .... a few days ago.
Again same symptoms. Again a jump start works ok and I drive it and park for about 5 hours, get in and no problems.
Then yesterday I get in and again it is low on volts.
I have checked and there are no lights on, no stereo, accessory (phone charger) unplugged.
So I am at a loss.
Would a "bad battery" behave like this = fail, work ok for months, fail, work for days, fail again?
If not I presume I have an electrical problem.
Something I have had for a long time is that the light behind the heater control (to illuminate in the dark) is sometimes on and sometimes off. Then a week or so ago for a few days the electric sunroof started playing up - opening and closing without me touching the control and not shutting when I moved the control to the shut position - I needed to move the control beyond that position.
Don't know if any things are linked.
I have now purchased a jump start pack and am off fishing for 24 hours in a remote place. Intend to return to the car every 4 hours and run the engine for 5 mins - I hope this will keep things ok - what do you guys think.
ANY advice would be gratefully received.
Thanks
Ed
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Yes, the battery could be causing the intermittent problem if it has an internal short. If it is original it is due for replacement now anyway. Take it to your local FLAPS and they can test it to confirm its condition.
The sun roof problem is fairly common on the late 90s A4s. I don't think that the problem is caused by a wiring short but I am not sure.
You might want to check the FAQ thread and history at the A4 AudiWorld forum for others that have experienced the same problem. http://forums.audiworld.com/A4 /
TonyJ 98.4 A5 1.8TQM APR
snipped-for-privacy@bigfoot.com wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

My 98 does the same thing. Irritating.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

My 98.5's sunroof works flawlessly. What exactly are yours doing (or not doing)?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

http://www.kris-hansen.com/Audi/srswitch.htm
Cheers,
Pete
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Beautiful! I have a project this afternoon. :-)
--
_______________________
Ed H.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.