E46 Peformance and Fuel economy

I have got a 2001 E46 320iSE 6 CYL..Sometimes when i start it ,it cuts out and when it is running it feels sluggish.I have replaced the Spark Plugs,
Air filter, Fuel filter Oil & filter, but it still remains a problem.I am currently getting about 23-25MPG... Could anyone help me in the right direction.. Cheers.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Could be a clogged catalytic converter. Have someone check the back pressure through the oxygen sensor port in the exhaust pipe.
Whitty wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
TXkgMjAwMSBNMyAoVVNBKSB3YXMgc3B1dHRlcmluZy9jdXR0aW5nLW91dCBiYWRseS4gVHVybnMg b3V0IDUgb2YgdGhlIDYgaWduaXRpb24gY29pbHMgd2VyZSBiYWQuIEhhZCAnZW0gcmVwbGFjZWQg YW5kIGl0IHJ1bnMgbGlrZSBuZXcuIEJUVywgbXkgZ2FzIG1pbGVhZ2Ugd2FzIHN0aWxsIGdvb2Qg d2l0aCB0aGUgYmFkIGNvaWxzLiBHbyBmaWd1cmUuIA0KDQoNCiJOaWVscyBQZXRlcnNlbiIgPDFn cjhkYW5lQGdvb2dsZW1haWwuY29tPiB3cm90ZSBpbiBtZXNzYWdlIG5ld3M6Z0l5ZG5aQUlQSTh2 WVozWm5aMmRuVVZaX3NTZG5aMmRAYWRlbHBoaWEuY29tLi4uDQo+IENvdWxkIGJlIGEgY2xvZ2dl ZCBjYXRhbHl0aWMgY29udmVydGVyLiAgSGF2ZSBzb21lb25lIGNoZWNrIHRoZSBiYWNrIA0KPiBw cmVzc3VyZSB0aHJvdWdoIHRoZSBveHlnZW4gc2Vuc29yIHBvcnQgaW4gdGhlIGV4aGF1c3QgcGlw ZS4NCj4gDQo+IFdoaXR0eSB3cm90ZToNCj4+IEkgaGF2ZSBnb3QgYSAyMDAxIEU0NiAzMjBpU0Ug NiBDWUwuLlNvbWV0aW1lcyB3aGVuIGkgc3RhcnQgaXQgLGl0IGN1dHMgb3V0DQo+PiBhbmQgd2hl biBpdCBpcyBydW5uaW5nIGl0IGZlZWxzIHNsdWdnaXNoLkkgaGF2ZSByZXBsYWNlZCB0aGUgU3Bh cmsgUGx1Z3MsDQo+PiBBaXIgZmlsdGVyLCBGdWVsIGZpbHRlciBPaWwgJiBmaWx0ZXIsIGJ1dCBp dCBzdGlsbCByZW1haW5zIGEgcHJvYmxlbS5JIGFtDQo+PiBjdXJyZW50bHkgZ2V0dGluZyBhYm91 dCAyMy0yNU1QRy4uLg0KPj4gQ291bGQgYW55b25lIGhlbHAgbWUgaW4gdGhlIHJpZ2h0IGRpcmVj dGlvbi4uDQo+PiBDaGVlcnMuDQo+Pg0KPj4
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Cheers for the reply. Do you think that it could be the Oxygen Sensor itself..
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I went through a simliar issue with my 2003 E46 ... It was very sluggish at higher speeds ... like a cylinder was "miss firing". Poor gas mileage. After 4 trips to the dealer - replaced the Oxygen Sensor, replaced the DME, spark plugs, etc... it was determined to be the #6 Ignition Coil ... they replaced all 6 of them under warranty ... runs great since then. Getting arou d 30 MPG on average. There was a TSB released this last summer for the E46's ... not sure if your year was included, but might be worth a look.
Best of luck.
In article
snipped-for-privacy@whitham1975.wanadoo.co.uk says...

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.