Excessive Fuel Consumption

I thought I might try here to diagnose excessive fuel consumption with a 1981 528ia . I am going through a tank full (70 litres) for 280 klms (160
miles). Which to say the least is alarming.
I have replaced the rotor cap and button. The fuel pump and filter are 6 months old. The plugs have done aprox 10,000 klms. I have stopped all the fuel leaks in the system bar one injector, that weeps..
I am at my wits end on this one..
Thanks Glenn
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

If it runs rough at all, I would suspect an air/vacuum leak. Or possibly a problem with the airflow meter (which is a mechanical balance affair). I don't know if Australian vehicles had a catalytic converter (US models since '79 did), but it can get plugged and cause power loss and other woes.
When was the last time the valves were adjusted?
FloydR (had a '77 530i - very similar)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
check fuel press. , the mass air flow would cause a rough running cond. check also the o2 sensor voltage
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Might be stuck in cold start mode, check the temp sensor on the thermostat housing and it's wiring. An average of 25+ mpg would be about right.
I saw an '81 520i with the same problem, air filter was filthy.
--
Who needs a life when you've got Unix? :-)
Email: snipped-for-privacy@unixnerd.demon.co.uk, John G.Burns B.Eng, Bonny Scotland
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.