slow starting ram

I've got a 97 ram with the 5.2 engine, and it takes about 4 or 5 seconds to get it started. I replaced the fuel pump about 6 months ago, so I'm sure it gets plenty of fuel pressure. Where do I need to start
looking to figure out what is keeping it from starting quickly? When I first got the truck, it would take just a quick turn of the key to get going. Thanks.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
When was the last time it had a tune-up and have you run any injection cleaner through it? How many miles are on it?
--
If at first you don't succeed, you're not cut out for skydiving


<bucky_katt snipped-for-privacy@yahoo.com> wrote in message
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Had the tune-up about a year ago, and it has about 110k on it. I hadn't run any cleaners through it because I was under the impression that 99% of the stuff sold was not any good. Or am I thinking of the wrong stuff at the parts store?
TBone wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

There are both good and bad ones out there and the best way to think of it is that you get what you pay for. You don't have to look for the most expensive one, just a name brand in the mid to upper price range. The injectors may also be wearing out after 110k miles and not giving an optimum spray pattern. I would try to clean them first and see if your starting situation improves.
--
If at first you don't succeed, you're not cut out for skydiving



Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Try this: Turn the key on, was about three seconds. Turn it off, then back on and see if it will start quickly.
Al
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I had the same problem with a 2.5 Dakota 96 and i solve it by cleaning the inyectors, at least 2 of them and the other 2 were replaced. CLT.
bucky_katt snipped-for-privacy@yahoo.com wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.