failing indicator

Dear Fiat-friends,
i have a 1998 Fiat Punto Sporting, and a strange thing happens lately very often. Sometimes the indicator stops working for a few times and sometimes it doesn't work at all. Then you hear a noise from
the stearingcollumn, that is best discribed as a slightly shortcircuit sound. And when i push the hazzardlightbutton to let it blinck ones, the problem is solved for a period of time. Has anybody experienced the same problem, and what can i do about it ??
gr Nico
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Usual first step is to try and find exactly where the noise is coming from, start by taking the steering column shroud off. From experience with Fiats probably not easy and you may need a longish Philips driver. Next try www.fiatforum.com to see if anyone else has the problem.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Thanks for the answer, but i have found out, that the problem was in the hazzardlightbutton and its relay. And because it isn't possible to replace only that button, i found a complete secondhand steering column unit and relpaced it. Now it is working like it should.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.