Fiat Marea Weekender ( Bravo)

This is doing my head in. Starter Motor problems. Sometimes my car wont start - you can hear the starter motor turning but the bendix is not engaging.
I've tried changing it with one from a scrap yard that tested ok, but still the same problem. Anyone got an electrical drawing for the above. ( I put Bravo in because I was told that the drawings are the same ) Help advice ???? Please Please - - - -
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Shrap wrote:

Teeth worn off the ring gear on the flywheel?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
John Moppett wrote:

no, its fine...aslong as the engine turns it starts but theres no gaps in flywheel and it won't turn...thanks though...
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

but the

That happened on an old Uno I once owned, but I think it was the teeth on the starter motor cog that were stripped.
Are you SURE you hear the motor turning?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I have the same problem on my bravo, if you solve it let me know!

the
still
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.