Turn signal doesn't flash! AH!

Hey all. Here's my problem:
I have a '96 Firebird. I use the tilt steering wheel a lot, and the turn signals now stay solid when the steering wheel is tilted to where
I usually use it to drive. When I tilt it back up or further down, they work fine.
I assume that a wire or something it getting pinched within the system when the wheel is tilted, but I don't know where to begin to fix it.
Any help would be GREATLY appreciated. It's starting to bug me a lot :)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Sounds like a problem in the multifunction switch in the column. Not DIY repair unless you know how to properly disarm the SRS system to get in there to service the switch.
Joe--ASE Certified Parts Specialist & 10th Ann.Club Tech Director '80 Carousel Red Turbo T/A, 26k orig. '79 "Y89" 400/4 speed 10th Ann. T/A, 57k orig '84 Olds 88 Royale Bgm 2 dr, 307 "Rocket" (lol), 141k and still going.... '80 T/A project car...
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Bigjfig wrote:

Actually might be worth checking the solenoid before that.
--
Martin
'01 Formula - MTI Air Box Lid, K&N Filter, Hurst-6,
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
actually I concur, or sometimes with tilt steering the wire harness gets pinched......and cut....intermittent contact...
Let us know how it works out

repair
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.