91 Ranger Temp Guage Problem

The temp guage on my 91 Ranger always stays over to the very far right (C) position but will move slightly when driving the vehicle for a while. I know
it is inaccurate but is it the sensor or could it be another problem?
Thanks,
Kamevil
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
How do you know it is inaccurate ? Maybe your thermostat has failed.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Test the gauge by removing the wire from the sender and touching the connector to the engine block while the ignition is turned on. Have a helper in the cab while doing this; if the helper reports that the needle swings over to the hot side of the gauge, replace the sender at the engine block. If there's only a little movement from the gauge needle, the problem is in the gauge or the wiring.
Tim B wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
my 4 cyl ranger temp gauge stayed to the left (showing cold). I pulled the stored codes from the computer and it had a coolant sensor out of range code. Check the sensor. John

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.