Engine Surge

Idle is only sligtly rough, but Engine surges when throttle is opened slightly. This happens when driving slow and steady with engine warm. I can duplicate with air cleaner off and hand open throttle. Spray from
both injectors is even fan and can be seen to increase and decrease. No Tach is present to log RPM. I have change throttle position sensor trying to solve this. Also Cap/Rotor, wires and plugs as part of regular maintenance. All Looked OK but changed any way. There is no fuel pressure gauge or place to install one that I can see to determine fuel problem. Disconnecting and pligging the EGR vacuum line solves problem, but may not be the cure.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
And the car is????

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
bimmster1 wrote:

1994 Chevy Z71 350 TBI / 4L60E Tranny
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Remove the egr and clean it up you have diagnosed what seems to be the root problem but low fuel pressure still could cause this, must be tested with a t fitting and gage at the fuel filter 10-13psi.

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Only 10 - 13 Psig for a TBI Engine? an I will try to install a "T" as all lines are Steel with fittings: ie, no rubber. Shep wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.