LeSabre 2000 Coarse Idle

Hello, I have been driving my LeSabre for just a few weeks now, 81K on the car. Idle seems just a bit coarse, not missing, but I can feel the vibrations of the idle. I just recently spoke with a friend who has
owned LeSabres for the past 10 years and he told me his 3800 engined LeSabres idle very smooth. Where should I start to pinpint why my engine idles coarse?
Thanks for any help,
Scott
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

The idle on my '01 with 120k is so smooth you don't feel it running. After six years though, plug wires can still look good but leak and cross fire. Although the plugs are good for over 100k, consider changing them and the wires. Sometimes when it is dark you can see the cross firing between wires. If you do, replace them.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
check fuel pressure regulator. these have a little problem with it. pull vaccuum line of regulator and check for fuel. if there is not a real sign of fuel there start it with line off and see if fuel comes out of the regulator. if so replace regulator. Edwin Pawlowski wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for these suggestions, today is the day for me to troubleshoot my idle problem. I'll let you all know what I find.
Scott
gmtech wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.