Defroster question for a Hyundai tech.

My rear defroster on my 02 Sonata is not working. There is a wire plug under my front drivers seat that is not plugged into anything. Could this be the
answer? If not, what is that plug for? I can't find anywhere it could go, unless I just did not see it. Thanks in advance!
John
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Wire plug is probably for power/heated seats. Not rear defroster.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

the
go,
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Does the on/off lamp on your defogger switch illuminate? (Check with the car running. It won't turn on unless the car is running.) If not, start by checking your fuses. If so, turn it on and go to the rear glass and check to see if you have 12V between the two terminals. If you get the 12V, you're looking at a grid problem. If you don't, you're looking at a problem elsewhere. You'll probably want to get a schematic if that's the case.
Most frequently, one of the wires is disconnected or the tab came off the window.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.