No spark when I crank her over

Hi Guys
Whilst cleaning my ignition system on my Hyundai Coupe 20 I accidently got some contact spray into one of the holes in the coil for th HT lead.
forgot about it and turned the car and now no spark. Do you guys reckon that its just the coild thats gone or something more sinister?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
You were cleaning your ignition system?? Pull the wires and dry it out before doing anything else.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
i, have a 1996 hyundai elantra and there's no spark,doesn't try to start, also new spark plugs new spark plug wires.a used manifold.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

If you don't have any spark, the car will never "try to start". You should probably take it to a mechanic.
--

-Mike-
snipped-for-privacy@alltel.net
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
You should check things like whether the check engine lamp illuminates when the key is on (as a check for computer operation) and the crank sensor is functioning.
Since you say you have new plugs, wires, and manifold, was there anything you did that may have affected spark?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Dear Shipp, I've been having this problem for many years when I turn her over!!!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.