1997 E420

I test drove a used 1997 E420 Today. This car is loaded with all options available. It has the traction control feature also. It seemed as though when I stepped on the gas there was a bit of a lag in
acceleration. Is this normal due to the traction control system being on the car? Thank you for your input and advice. The car is nice with 108,000 miles and asking price is $6,500.00 from a private seller.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

ASR should not introduce any lag until it operates. But if there is some tyre slip first, then the early implementations of ASR where pretty conservative and slow in regaining engine power.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The very brief moment of hesitation before accelerating is a Mercedes trait. Whether you example is longer than normal is hard for us to judge via the web.
I definitely have to modify my driving style when I get into another car.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I am used to driving a C220. WHen I step on the accelerator it is all go with that car. The E420's pedal is easy at first when you are first into it then it tightens up the rest of the way.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

i've never noticed this in my 98 E320?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.