acdelco factory radio clock not keeping time

HELP I recently installed a GM acdelco factory radio in my s10 Model No 16232131 everything works with exception of the button lights & the thing that
really is annoying is The clock doesnt keep time FOR EXAMPLE I can set the time to say 12:00 drive around for a half hour it will keep time and say 12:30 when I stop and shut motor off ill come out a half hour later start up and instead of saying 1:00 it will still say 12:30 and somtimes it even reverts back to its default of 1:00. But It keeps my radio stations in memory I can call up any preset stations I programed NOTE:this radio DOES NOT have a SET Button like some early 90s models it has an HR & Min Button. I had anouther radio same model it does the samthing (CD doent work thats why I replaced) thats what lends me to think its something else I did. Also if u have any idea why the lights dont work tune and volume light works just buttons dont
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
CROCDYLE wrote:

That sounds like you have a wire in the wrong place or not hooked up. Some stereos have a wire to the dash lights so they dim with them and come on/off with them.
Some stereos also need a constant power line for the clock. My son has one of those. His stations will stay, but the clock won't when he first hooked it up. It had light issues too I think. I then convinced him to RTFM to see what wire is 'supposed' to go where. The wire he thought was for power antenna actually was a constant power in line....
My stereo is strange. I broke the fuse for the constant power line, yet everything still works including station memory....
Mike 86/00 CJ7 Laredo, 33x9.5 BFG Muds, 'glass nose to tail in '00 88 Cherokee 235 BFG AT's Canadian Off Road Trips Photos: Non members can still view! Jan/06 http://www.imagestation.com/album/pictures.html?id !15147590 (More Off Road album links at bottom of the view page)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.