HELP: Turn signal blinking problem

Hello all-
I have a 1998 S70. Today on the highway my turn signals stopped functioning properly. Now when you use the turn signal stalk to turn on
the left or right signal, the signals light up, but do not blink. (They turn off if you reset the stalk at its neutral position). If I press the Hazard Light button, nothing happens (the lights to not light up). My headlights, high beams, windshield wipers, etc. all still work properly. Has anyone had any experience with a problem like this? I would much appreciate some help.
Thanks,
ES
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The turn signal problem sounds like the flasher is not functioning it's also possible the hazards are using the same flasher, Did these two problems happen at the same time?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
In an earlier contribution to this discussion,

It's possible that you have a duff flasher unit. This does the business both for the direction indicators and for the hazard warning, and is located immediately behind the hazard button.
But first check fuses # 13 and 27 - it's possible that one of these may have blown, although they would also take out other things, such as central locking.
--
Cheers,
Roger
______
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Check your lamps for internal shorts

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.