ECM configuration

I am changing from a 4.3 to a 5.7 in my 85 K10 PU. Can I use the 4.3 ECM and change the chip or must I replace the ECM with one for a 350?
BillG

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Same ECM, different PROM and MEMCAL/CALPAK.
Doc

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I need help solving a problem . I changed my fuel pump ,had my truck running started it a few times and waited a while went back to start it again . the ECM fuse blew and everytime I change the fuse and turn the key the fuse automactically blows . What can cause this. help .
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
sounds like you have a direct short to ground... A hot wire that is grounded somewhere. Check the connections on any wiring you did, make sure you have not pinched any of the wires.

started it a few times and waited a while went back to start it again . the ECM fuse blew and everytime I change the fuse and turn the key the fuse automactically blows . What can cause this. help .
--
Elbert Clarke
elbert.clarke**@us.army.mil
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.