A6 shakes after long run

Car is 99' A6 with only 38K on the clock and perfect maintenance. It's primarily used as a commuter car with occasional short hops at highway speeds (70+mph). I took the car on a long trip with extended high speed
driving and noticed a strange behavior: As I'm slowing down to exit the Interstate (30-50 mph) the car started to shake and sort of loose a little power; I was afraid it might stall on the exit ramp. Any ideas where to look for problems?
P.S. The car is back as a commuter and things are back to normal but not sure if this shaking will return on extended high speed travel.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Just some questions. Automatic or manual transmission? Recent oil change and level is OK? Did the Engine Check light come on? Regular fuel or ???? Was it real cold and or snowing at that time you noticed a problem?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
A6 Q Automatic 2.8 L. Oil is Mobil1 5-30, full and new (as always). No Engine Check light. High test gas and temperature was in the 30's F. BTW, after I stopped for 20 minutes I drove back on the interstate with no vibration again.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hmmmm JMHO but.,...... 38K miles on a 7-8 year old car is not a lot, it is too little. I don't even consider it broken in well until the odometer goes past 100K miles and yours is only driven about 5,000 miles a year and probably short 20 minutes of driving each little trip. ;-) It could be that the vehicle needs to be driven on a nice long 4 hour highway trip. Maybe even using a upper engine cleaner in the fuel tank in case you have some deposits inside of the engine.
Short trips are not typically good for the engines. The engines don't maintain operating temperature long enough and it is also considered "abnormal" driving. It can cause exhaust systems to accumulate water from condensation which does not have a chance to "burn off". This can apply to the engine internals also, deposits can develop on the cylinder head valves and water will form inside the engine the oil.
Have you ever heard of the term "Italian Tune Up"? Driving it hard and fast for awhile on the highway can do wonders! <g>
JMHO
--
later,
dave
(One out of many daves)
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Agreed, but just a small note of "caution". Please make sure your engine is at normal operating temperature, ie, water temp in the middle of the gauge, then a further 5 minutes for the oil to catch up - before giving it max on the loud pedal ;-)
Rgds, Sean
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
How about tires. Air pressure? Been rotated lately? Could have lost a weight.
--
please reply to bargerw NO @ SPAM bellsouth.net and remove the NOSPAM


"Tony" < snipped-for-privacy@comcast.net> wrote in message
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

One of your coils or power output stages is going south.
Since it quit after you shut it off, I'm guessing coil. It'll return, and stay. They you can find it and fix it cheaply.
E.P.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.