Transmission Clunks

I have a 1996 Audi A8 Quattro (ABZ) and recently i hear a distinct *Clunk* sound accompanied with a jerk when engaging the reverse gear. This happens when the engine is cold or warm.
I only experience this in the when switching to Reverse all the others including park, drive or the other 3,2,1 are all fine.
i just had the transmission rebuilt along with the valve body (3 months back and used original ATF fluid)but the problem hasn't gone away.
There are no other sounds while driving except I also experience a jerk while the transmission changes from 1-2-3-4 and back (4speed ZF transmission)
The drive is very smooth after it touches 4th gear and the pickup and acceleration seems fine.
i have shortlisted possible causes from what i've read
* U-joint (never checked or replaced) * CV-Joint (never replaced) * F125 switch (multifunction) (giving occasional error with scan) * Torque converter (not checked) * Engine mount (currently leaking) * Transmission mount (not checked) * Valve Body (jammed piston)
Can it be any of the above or something completly different _________________ Boney F Varghese
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@gmail.com wrote:

This is most likely your problem.
Bad transmission mounts or driveshaft center bearing could also be the problem.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

unit...
RM
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.